Technology Requirements - Online Learning

Technology Requirements for Online Learning

In order to be successful in your courses, you will need access to the following:

Desktop Browser

Supported Browsers

Browser Version(s)

Maintenance Browser Version(s)

Microsoft Edge

Latest

N/A

Microsoft Internet Explorer© 

N/A

11

Mozilla Firefox© 

Latest

N/A

Google Chrome© 

Latest

N/A

Apple Safari© 

Latest

N/A

check your system compatibility

Browser Issues

  • Many of the problems people report are related to Internet browsers, not D2L. If you are experiencing technical problems, consider your browser first.
  • We recommend using Chrome or Firefox. We hear the most complaints from students using Safari (Mac) or Edge (PC).
  • Switch to a different browser. Regardless of the browser you use, one first step when having problems is to try switching to a different browser.
  • New Incognito Window. Try opening a new incognito window since that avoids the cache. If that works it means the cache needs to be cleared.
  • Clear your cache. Browser-specific steps are detailed here

Tablet and Mobile Support

Device

Operating System(s)

Browser

Supported Browser Version(s)

Android

Android 5.0+

Chrome

Latest

Apple

iOS

Safari, Chrome

Latest

Windows

Windows 10

Edge, Chrome, Firefox

Latest

CHECK YOUR SYSTEM COMPATIBILITY

Respondus Lockdown Browser

Windows Requirements:

  • Windows 10, Windows 8, Windows 7
  • 2GB RAM
  • 75MB of Hard Drive space

Mac Requirements:

  • OS X 10.10+
  • 512MB RAM
  • 120 MB of Hard Drive space

More details can be found at respondus.com.

Zoom

System Requirements

  • An internet connection – broadband wired or wireless (3G or 4G/LTE)
  • Speakers and a microphone – built-in or USB plug-in or wireless Bluetooth
  • A webcam or HD webcam - built-in or USB plug-in
  • Or, a HD cam or HD camcorder with video capture card

Supported Operating Systems

  • Mac OS X with MacOS 10.7 or later
  • MacOS 10.6.8 (Snow Leopard) with limited functionality (Zoom version 3.6)
  • Windows 10
  • Windows 8 or 8.1
  • Windows 7
  • Windows Vista with SP1 or later
  • Windows XP with SP3 or later
  • Ubuntu 12.04 or higher
  • Mint 17.1 or higher
  • Red Hat Enterprise Linux 6.4 or higher
  • Oracle Linux 6.4 or higher
  • CentOS 6.4 or higher
  • Fedora 21 or higher
  • OpenSUSE 13.2 or higher
  • ArchLinux (64-bit only)

Supported Tablet and Mobile Devices

  • Surface PRO 2 running Win 8.1
  • Surface PRO 3 running Win 10
  • iOS and Android devices
  • Blackberry devices

Supported Browsers

  • Windows: IE7+,  Firefox,  Chrome,  Safari5+
  • Mac: Safari5+,  Firefox,  Chrome
  • Linux: Firefox, Chrome